Revision history   OpenPOWER Library

 4.1.1. Pseudo operations

An assembler compliant with the ELFv2 ABI must support the following pseudo operations:

.abiversion

Specify the ABI version. Only ABI version 2 (to indicate the ELFv2 ABI) is required to be supported. ABI version information must be encoded into the ELF header's e_flags field.

.localentry

Specify the local entry point of a subroutine. Local entry point information must be encoded into the subroutine symbol's st_other field as defined in section 3.4.2 "Symbol Values" of the ELFv2 ABI specification.